WanamLite XXUGNG2 V2.9 Android KitKat 4.4.2 Xposed

Filed in Galaxy S4 LTE by on 11 July 2014 27 Comments
Welcome to WanamLite Rom for Galaxy S4 LTE I9505.
  • Flash it at your own Risk
  • Your warranty will be void
  • I don’t take any responsibility for any Damage

This Rom is a Stock Odexed with no Application neither Framework modification.
All my Mods are supported trough my application “Wanam Xposed”.

Screenshot_2014-07-11-12-17-48Screenshot_2014-03-06-14-13-53Screenshot_2014-01-17-13-53-01 Screenshot_2014-01-17-13-53-45

Features :
 Based on the latest Official KitKat FW
 Stock Odexed & Rooted & Busybox
 Adam Kernel (SELinux Set to Permissive, Init.d support, Disabled Knox/TIMA verification and many other tweaks)
 Large APN list
 Debloated (removed Samsung Apps and Social Hubs, available on a separate patch)
 Clean build.prop for best Market compatibility
 Stock Keyboard with all supported languages enabled
 Kies support
 Removed Knox Apps & Services
 Added Media read/write permission for external sdcard
 Auto wipe cache & dalvik-cache before flashing

Important Notes:

  • Make a Nandroid Backup (Including EFS)
  • A Wipe data is recommended if you came from an AOSP or 4.2/4.3 based Rom

Change-log :
 Update base to GNG2
 Update Adam kernel Ramfs to GNG2
 Minor config fixes

Rom Download:

Optional:

  • Removed Apps (MD5: B17C41F2FA10DE5F16FD91BB506EAADB)
  • Modem (“Optional” to be flashed through Odin 3.04)
  • Bootloader (“Optional” to be flashed through Odin)

Mirror1 – Mirror2 (Thanks to Romcook and Romhut for mirroring my files).

Installation steps:
 Copy Rom file to Internal sdcard
 Flash it through CWM recovery
 Don’t use the Root option from recovery (you don’t need it)
 Reboot, Install Xposed Installer and install the latest framework, install Wanam Xposed, enable it on the Xposed Installer
 Reboot & enjoy

Tags: , , , ,

  • wire67

    Hi Wanam, how can I enable the LogCat? can’t see any data in Eclipse/command/Rooted CatLog…

    • http://wanamlite.com/ Mohamed Karami (Wanam)

      Enable it through STweaks App.

      • wire67

        Thank you this worked :)

  • Tzachi

    What is the benefit of upgrading from 2.7? I can see the only thing that has changed is the baseband. What is the benefit of moving from one baseband to another?

  • doru

    Will this wotk with old bootloader ? If I flash this bootloader will I still be able to go back to my backup after that? Thanks…

  • Rakesh Prajapat

    Nice features of this Android Version. people also get here more about iPhone feature. http://iphone6update.com/

  • Boudy Rifai

    wow best rom
    battery life is amazing
    better than wanam 2.6 a lot

  • Mutzenmann

    Thank you very much Wanam. Can you please please consider creating a flashable zip which lets me completely debloat your roms? There is still so much Samsung crap left after the install. After each rom update I spend 1+ hour deleting it with Titanium Backup.

  • Mason

    Thank you so much for this Wanam!

    I am currently running version 2.7 under XXUGNF1, can I directly install this directly without updating my firmware first to XXUGNG2?

    Thank you in advance!

  • Antonio Ramos Garcia

    I have i9505 with android 4.2.2 wanamlite rom adam kernel. It works very very well and then never i have upgrade to 4.4.2. Which are the beneficts of upgrade to 4.4.2? Works it better than 4.2.2? Have kitkat wanamlite rom the same speed than 4.2.2 and i can use the record calls option? Can i install viper4android fx on it? Thanks

  • Feisar

    Thanks Wanam, works fine!

  • Sheilame Castillon

    Hi. Can i use rom on my s4 i9505 carrier locked on globe.im from philippines. Thanks

  • disqus_5ZLZNPPzQt

    Clean and stable rom, thanks, it’s amazing.

    Do I need to have the XXUGNG2 installed? Would it benefit or can I just use XXUGNF1 and put this WanamLite on it?

    • http://wanamlite.com/ Mohamed Karami (Wanam)

      No, you don’t need it.

  • AirSac

    Why don t update modem ??

    • http://wanamlite.com/ Mohamed Karami (Wanam)

      I didn’t try it, did you use old Odin version?

      • AirSac

        I flash with odin 3.07..

        • AirSac

          No one flash new modem ??

          • gazza1971

            Same problem as you, flashed using odin 3.04. Remember to put the zip file in Phone field.

            Ciao

          • AirSac

            Zip file ?? modem is “GT-I9505_WanamLite.XXUGNG2_Modem.tar.md5″ , no zip file..
            I flash with odin 3.09 now, in field CP, but always old modem…

          • http://wanamlite.com/ Mohamed Karami (Wanam)

            Follow the notes, ir must be flashed through old Odin 3.04 (Phone filed).

          • AirSac

            i try firts with odin 3.04 , BUT don’t update the old modem. Have you try ?

          • gazza1971

            Airsac use odin 3.04 and work perfectly. Sorry is tar not zip file.

          • AirSac

            But The modem is .md5 , no .tar. I must rename it ?

          • http://wanamlite.com/ Mohamed Karami (Wanam)

            It is a tar + md5 hash at the end of file, so it should work properly.

          • AirSac

            nothing..i flash a lot of way modem with odin 3.04 , but after rebook, always old modem. Wanam, do you try this update ?

          • Olav

            don’t reboot phone automatically in download mode via power-button!
            1. shutdown your phone
            2. manual boot phone in download mode (volume down + home + power)
            3. flash modem
            4. reboot phone
            you should now see the new version of the modem…